[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

Re:Does this sound like a fuel pump problem or ignition failure?

Hi guys, 

I was the one who posted the original article. The problem is 
finally solved! :) It is the fuel pump that is going bad! I am just
surprised that the fuel pressure and volume check turned out ok even
though the pump was failing. The only clue that it was failing was the
fact that the pump got very noisy intermittenly and also the interval 
between stalling was getting shorter i.e. from a couple of hour driving 
to just under an hour of driving before it happened. 

Anyway after two fuel pump relays and 3 very frustrating weeks later the
problem is fixed. The new pump is $198 plus tax. My mechanic put the new
one in without charging me labor since he felt kind of bad that the last
one only lasted 16 months(Bosch warranty is 12 months unlimited mileage).

What a difference the new pump made! The car seemed to idle alot smoother
and also accelerate alot better! :)

I guess sometime even the fuel pressure and volume check do not 
necessary give a clue that the pump is failing! :(

Anthony Chan
Adminstrative System
Information Services
Seattle University

Internet: chan@seattleu.edu
Phone: (206) 296-5553
Fax: (206) 296-5561
>Hi guys,
>Does anyone know if there is a screen inside the fuel tank of an 85' 5000s?
>My 5000s just started with this weird problem last weekend, it will suddenly 
>lost power and then stall completely but you can start it right up. It usually
>happen after at least one to two hours of driving. The fuel pump was replaced
>about 16 months ago. It usually died after a buzzing noise from the pump.
>I replaced the fuel pump relay. I have the fuel pressure checked also volume
>checked. My mechanic even hooked up a fuel pressure guage to the fuel system
>and drove around with it for 4 days but of course nothing happen, the 
>problem never reappeared. The pump was real quiet. He checked a bunch of other
>stuff like the fuel accumulator, differential pressure regulator(just been
>replaced a 2 months ago), fuel filter been replace. Also all five fuel 
>injectors were replaced 8 months ago.   
>It cut out 5 times on the freeway last weekend, it was fun diving for 
>shoulders! :P 
>Does anyone have any idea what causing the problem? 
>Anthony Chan
>Adminstrative System
>Information Services
>Seattle University