[Author Prev][Author Next][Thread Prev][Thread Next][Author Index][Thread Index]

RE: Wheel shake and light steering...

Gerard wrote:

	>I've got that leaking turbo oil-line fixed now. Also, the left
	>CV joint of my car had to get new grease and all wheels were
	>new Ferodo Platinum brake pads. Now, at about 100km/h, there is
	>wobble coming from the front left wheel. 

Unbalanced or deformed tyre is the most common cause. Also bent rim, bad
wheel bearing or worn tie rod end.

	>Also, and this has been
	>happening for a while, the steering gets awfully light and it
	>as if the car just wants to wander all over the road. 

The car needs aligment or the tie-rod ends are worn (this could also
contribute to the wheel wobble)

	>And another
	>thing, sometimes on turning the steering the is a "click" and I
	>feel it through the steering wheel. Could this be the steering

Could be, but first check if the rack mounting bolts are secure (I had
similar problem caused by loose RH mounting bolt - on your car this will
be probably LH bolt). Also check if the tie rods to rack bolts are

	>light steering feel that makes the car feel like it is running

A good description on how a car with worn tie rod ends or too much
toe-out behaves

	>Or is my car just running perfectly and I'm judging it against
	>how it used to be before this service I just had? :)

Changing brake pads and CV joints should not give symptoms like that

Aleksander Mierzwa
Warsaw, Poland
87 Audi 5000CS turbo (mine)
88 Renault Medallion wagon (mom's)
91 mountain bike (just in case both cars broke at the same time :-)