What's This/What's It Do?

Kneale Brownson kneale at coslink.net
Mon Apr 11 15:22:24 EDT 2005

When I had intermittent boost (1.3, 1.4  and then 1.6-1.7 and so on) a
month ago, Ingo suggested the waste gate frequency valve electricals, so I
attempted to take this connector
http://www.pbase.com/kneale_brownson/image/41941930   apart for cleaning.
Because of the close quarters, I couldn't hold the spring retainer down and
take the connector off.  But after messing with it and also taking down the
ventilated boot for the multifunction temperature sensor, I got back my
good boost, so I left everything alone.

Then, a week ago, just before my 3K round trip to Snowmass, I was driving
in wet conditions and the  normal boost disappeared, so I got this
connector off by holding down the spring with a tool instead of my fingers
and prying it apart with another tool.  The prongs inside were bright and
shiny, so I sprayed both ends of the connection with an electrical contact
cleaner (CRC, I think), let it evaporate and then added a little dielectric
grease before reinserting the connector.  Still no good boost, but the trip
was on anyway.  So I only had 1.1 or 1.0 boost in the mountains (8-9K
feet), but the car ran OK otherwise the whole trip

Anyway, what's the connector indicated by the arrow in the pix do and what
do I probably need to replace?  The fixture onto which the connector goes
looks corroded at least on the outside, and some of the corrosion appears
cracked from my efforts to get the connector off a week ago.

More information about the 200q20v mailing list