UFO brake question

db cornett dbcornett at yahoo.com
Wed Apr 30 14:12:32 PDT 2008

       Don't get me wrong.... I like the performance of the UFO brakes on my '91 2C20v.  Especially with the Porterfield R4-S pads I use on the street.
       The problem is the steering wheel shakes when the brakes are applied.  Warped rotors is my guess too.  I've gone through 4 sets (2 used, 1 reconditioned, 1 new OEM) of UFO rotors in the last 3 years.  2 years ago I replaced all the suspension bushings and strut mounts with OEM.  I also replaced the rack rod ends at that time.  I was using Pagid Reds then.  In an attempt to sort this out I went to the R4-S pads when I installed a new set of OEM rotors last year.  I bedded in the pads as per Porterfield recommendations.  I've triple checked all fastener torques, made sure the rotors were mounted to rust free, clean mating surfaces on the hubs.  The calipers are free to slide on their mounts and the caliper pistons are rust free and stroke just fine.  The front end alignment was checked last month and is in spec.  I am using H&R springs with Bilstein HD's.  Oh yeah, I've got 197k miles on the clock... it starts quickly and pulls hard to 7000erpm (MTM chip & waste gate
 spring).  I don't baby the brakes.  I get them smoking HOT every once in awhile trying to sort this out.
       So with all that explanation.... does any one have first hand experience solving this problem with the UFO's?  Other than installing a BIRA system or someone elses version of the same.
       Cradle mounts?  Strut mounts shot?  Pad material transfer?  Anything?  Anyone?  Bernie?
  Cheers, Doug  

Be a better friend, newshound, and know-it-all with Yahoo! Mobile.  Try it now.

More information about the 200q20v mailing list