Check engine light not working?

Kenneth Keith auditude at
Sat Nov 22 15:12:35 PST 2008


I tried to pull codes to see if there were any faults that would explain the
unassisted 1.5bar boost I'm getting (I tested the TPS and tried running it
without the MFTS connected, no change, although I may crack open a TPS and
resolder inside anyway), and it turns out my check engine light won't light

It doesn't light up when I turn the ignition on either.  I have the
instrument cluster out (so I can re-solder the cracked tracings and replace
a bulb) and there was no bulb in the check engine socket.  I put a bulb in,
but it still won't light up with key on or when pulling codes.  I have
verified the bulb is working by swapping it with the seat belt and airbag
bulbs and the problem stays with the check engine bulb socket.

I was able to run output tests and everything is working, and I swapped in
another 3B ECU to see if the check engine light would come on with that in
case that circuit was bad in the ECU, but I didn't get any check engine
light response with the other ECU either.

Just to confirm, the check engine light socket is the one with red/green and
black/blue wires going to it?

Is this something that's been experienced before?  I didn't find anything
from the AF search function.



More information about the 200q20v mailing list