Now No Start! Was: Check engine light not working?

Kenneth Keith auditude at
Sun Nov 23 00:11:10 PST 2008


Geez.  I was seriously happy only moments ago as I had fixed a few things on
the 200q20v tonight and believe I found the cause of the low boost.  I was
in the dash and fixed the cluster issues, and the check engine light started
working.  I was able to pull codes, which were 4444 aka no faults, which had
me taking a step back to reevaluate my low boost issue.  I went to test the
BPV for leaks, and I discovered the same thing that got me before with these
cars. I was fooled into thinking the BPV signal hose was in great shape
because the two ends looked brand new, but sure enough it was baked and
broken in the middle where it passes the EM.  I patched the hose and cleaned
myself up after a long night of working on the car for a rewarding drive
with full boost...

WTF!  The car wouldn't start!  It would only crank.  The check engine light
doesn't come on any more either, with either of my ECUs.  I checked the
Motor Moteur fuses and they are intact, as if fuse 13 for the fuel pump.
 Earlier today I unplugged and checked every fuse and made sure they were
all the right amperage, but the car ran after that.

Now when I turn the key on, I hear a relay clicking twice, presumably the FP
relay, but I don't hear the fuel pump cycle.  I know the fuel pump doesn't
run unless the flywheel is turning, but doesn't it cycle once with the key
on to prime the system?  If so, mine's not doing it.  My fuel pump has been
very loud since I got the car, the characteristic angry bee's nest sound,
but it's not had any problems and has never not started before.  I ran a can
of Seafoam through it a few tanks ago, and aside from the loud fuel pump
(and low boost), everything's been normal.

Aside from the suspicious no fuel pump cycle with key on, the only things I
did since the last time it ran was to patch the BPV hose, and tighten a bolt
in the front of the block that I noticed was hanging out, which is for the
bracket that acts as a guide or guard to the power steering pump.  I did
yank the BPV hose out of it's routing along side the boost pipe, toward the
throttle body, and I had the WGFV disconnected when I pulled and reinstalled
the BPV.

I had the ECU disconnected a few times, and I was wrestling with it for
quite a bit as I couldn't get the forward part of the bracket to release
it.  I finally had to unscrew the bracket from the car and get it off the
ECU.  I suppose I could have damaged the harness in that area, but I doubt
it.  The first thing I thought when it wouldn't start was that I left the
ECU disconnected, but it was connected and latched fine.

Right now I suspect the fuel pump, but that doesn't explain the check engine
light not coming on with the key on.  I wonder if the ignition switch can
fail in a way that would cause that.  I have another fuel pump that I can
swap in, but I just put 3/4 of a tank in.  Since the fuel pump was noisy, I
guess I'll go ahead and swap it anyway.  Another thing I haven't done yet
but was coming up next was to replace the fuel filter.

Prior to wanting to pull codes today to check for low boost causes, I didn't
notice if the check engine light was coming on with the key on.  I don't
remember if I started today without the check engine light functioning, but
it did start when the light did function, so maybe the no start condition is
related to the no check engine light.

If anyone has any ideas, please let me know. <sigh>


On Sat, Nov 22, 2008 at 4:12 PM, Kenneth Keith <auditude at> wrote:

> 200q20v'ers,
> I tried to pull codes to see if there were any faults that would explain
> the unassisted 1.5bar boost I'm getting (I tested the TPS and tried running
> it without the MFTS connected, no change, although I may crack open a TPS
> and resolder inside anyway), and it turns out my check engine light won't
> light up.
> It doesn't light up when I turn the ignition on either.  I have the
> instrument cluster out (so I can re-solder the cracked tracings and replace
> a bulb) and there was no bulb in the check engine socket.  I put a bulb in,
> but it still won't light up with key on or when pulling codes.  I have
> verified the bulb is working by swapping it with the seat belt and airbag
> bulbs and the problem stays with the check engine bulb socket.
> I was able to run output tests and everything is working, and I swapped in
> another 3B ECU to see if the check engine light would come on with that in
> case that circuit was bad in the ECU, but I didn't get any check engine
> light response with the other ECU either.
> Just to confirm, the check engine light socket is the one with red/green
> and black/blue wires going to it?
> Is this something that's been experienced before?  I didn't find anything
> from the AF search function.
> Thanks,
> Kenneth

More information about the 200q20v mailing list