[BiturboS4] RE: KO3 S4 blown turbo?

Michael Kuriger michael at isuzu-mods.com
Sun Apr 6 15:23:56 EDT 2003

wow, I can't believe all these problems!  My S4 has 13,000 miles on it
and has been giec chipped since a couple weeks after I got it.  no signs
of trouble yet...  must be a few bad ones in the bunch :-(


Erik J. Engstrom wrote:

>Consider yourself lucky with a non-chipped car to have made it to 52K miles
>before this happened, everything has failed on my car between 7k and 41k and
>parts are still dropping off while the g*dd*mn car is parked at the dealer.
>I would insist that Audi cover the repairs under the initial warranty, if
>your extended doesn't cover all of the work. The replacement KO3 turbo's are
>much better than the originals placed in the car. Mine were replaced about
>350 miles ago under warranty at a manufacturer warranty cost of about
>$10,000. I have some nice pictures of my entire car taken apart and since my
>S4 has been in the shop about 60 business days now, I'm considering taking a
>position at the dealership just to be closer to my baby.
>After splitting four sets of bypass valves, I am also very used to the sound
>you are describing. There is also a disconcerting lack of boost when these
>cheap parts rupture. I've also been told that my turbo's were failed - hence
>the check engine light. But I never saw the actual report, dealer just
>replaced them.
>Good luck,
>BiturboS4 mailing list
>BiturboS4 at audifans.com

More information about the Biturbos4 mailing list