[BiturboS4] annoying squeak

Michael Kuriger michael at isuzu-mods.com
Mon May 26 21:59:22 EDT 2003

Mine squeaked as well.  I'm not sure exactly what I did to fix it but I
believe I just had to fold it down and back up.  whatever it is it will
surely return once the seat settles in the upright position again


Foobar88 at aol.com wrote:

>[ Picked text/plain from multipart/alternative ]
>Hey all,
>I've been getting an annoying metallic squeak/grinding noise coming from the
>rear passenger seat of my avant.  The noise goes away when someone is sittin
>gin the seat, but is very persistent when no one is there, especially when
>driving around on crappy DC roads.  Have any of you had this problem?  What did
>you do to fix it?  Any suggestions?
>Also, does anyone have any experience with aiming the headlights manually?  I
>asked my dealership to aim them higher, but when I got the car back, they
>were even lower than before.  After I asked them to aim them higher agian, they
>are still far too low- the center of my highbeams' focus hits the pavement
>about 25 feet in front of my car.  Seeing as how I drive around areas that are
>literally infested with deer, this is very dangerous, and I would like to fix the
>problem ASAP without having to deal with the dealer.  Other than that, the
>car is fine, except for the occasional cold start stumble- which the dealer
>can't seem to fix either.
>Matthew Ribe
>2001 Imola Avant
>Amherst College '06
>BiturboS4 mailing list
>BiturboS4 at audifans.com

More information about the Biturbos4 mailing list