[BiturboS4] S4 MAF's

Step88 step88 at kc.rr.com
Tue Nov 11 16:46:14 EST 2003

The MAF went out in my 2000 at about 32k just a few months ago.  The check
engine light came on when I was on vacation and at high altitude.  Didn't
know if the altitude had anything to do with it, but the car ran normal and
the light eventually went off for a few days once I returned home.  When it
came back on again, I took it the the dealer and they diagnosed the MAF
(alas, no VAG so I must rely on the dealer).  They replaced it with stock.

Coincidentally, the very next week after getting the car back, the anti-lock
brake unit started leaking and had to be replaced.  Expensive piece.  Those
are the only problems that I've had in a year of ownership.

----- Original Message -----
From: "Al Adler" <adlere at sourcecodecorp.com>
To: "BiturboS4" <biturbos4 at audifans.com>
Sent: Tuesday, November 11, 2003 2:28 PM
Subject: [BiturboS4] S4 MAF's

> Hi all,
>     Its looking like I need to replace the MAF on my 2000 S4.  From what
> I've read it seems that the MAF's used in the 2000's are fairly
> unreliable and that they use different ones on the newer S4's. I've also
> seen that some tuners sell RS4 MAF's as well(usually with the RS4
> turbos). I'm wondering if anyone has replaced the MAF in their 2000 S4
> with anything but the stock part and how well that worked, or if it even
> feasible without reprogramming the ECU. I'd also like to hear from
> anyone that has had a MAF fail in a 00 and how many miles they have got
> out of it. Mines at 53k and seems to be going slowly but surely.
> Thanks
> Al
> _______________________________________________
> BiturboS4 mailing list
> BiturboS4 at audifans.com
> http://www.audifans.com/mailman/listinfo/biturbos4

More information about the Biturbos4 mailing list