[Biturbos4] Console Display Acting Up

j y jimnetpa at yahoo.com
Thu Jan 19 13:06:30 EST 2006

Just like other display problems - I suspect that your only recourse is to replace the instrument cluster. Clair parts has half decent prices on re-manufactured instrument clusters - there might be better deals out there - probably have to do Google search to find them.

David Bray <brayd at rogers.com> wrote:
  Happy New Year, Listers!

I have an issue I'd like to pass by everyone.

My centre display is acting up, but not like what's been previously
reported on this list. In the past, people have complained that one or
more lines of the LED display will go out (and perhaps get progressively
worse). Instead, mine has an irregular-shaped "splotch" that lights up
and traverses diagonally from the centre area (where the outside-temp
might be displayed), into the upper area (where the current radio
station would be shown). BTW, the "splotchy" area appears brighter than
the normally displayed characters and if you look at it with the vehicle
off, you can see its shape outlined in the display area.

It started one really cold day (-15-deg C) and has been getting worse
ever since. Once the car warms up, the affected area actually retreats
a little, but never goes completely away. Then next morning, after
another cold Canadian winter night, it will have grown a little larger.

Has anyone had this happen to them? Can this be "fixed" somehow, or
must the display be replaced?

TIA for any help/advice!

'01 S4, 6spd (stock) 

Biturbos4 mailing list
Biturbos4 at www.audifans.com

Yahoo! Photos
 Ring in the New Year with Photo Calendars. Add photos, events, holidays, whatever.

More information about the Biturbos4 mailing list