Cruise Control Problems

Alex Kowalski hypereutectic1 at
Mon May 15 13:48:17 EDT 2006

Joseph Mott wrote:

>Wondering if anyone has BTDT w/ cruise control problems on a '91 Avant.
>I've checked fuses, tested the throttle servo w/ vacuum, tested the
>brake and clutch switches to ensure they hold vacuum and dump vacuum
>when depressed.  I teed the line from the pump and it makes slight
>vacuum when setting cruise or hitting resume, but not much.  I'd go
>through the test procedure in the Bentley book, but I can't even find

I don't know if the cruise control unit is the same on a '91, but this might
be worth a try.  It's almost a boneheaded thing, but:

On my car, an '87 5KCSTQ, I had a similar problem until I located it and
found that one of the screws that attached the CC controller in place had
"gone missing" and as a result the connector at the back gradually worked
itself loose until the cruise became flaky as the control unit shook
around.  Worked sometimes, hit a bump it stops, works other times, etc.,
etc.  You get the idea.  Find the CC control unit and make absolutely sure
the connector is attached properly and that the unit is attached to whatever
surface it's supposed to be attached to ... well ... the same way.

I don't know about the '91, but on my car the CC unit is a silvery box with
a bracket on the back, about 1 1/2x the size of a pack of cigarettes.  On
the '87 it's on the driver's side.

Alex Kowalski
'87 5KCSTQ - "Gretchen"
'86 5KCSTQ - "Sessa"

More information about the quattro mailing list