stuck odometer, type 44, infamous gear is intact - Update

kbogach kbogach at
Fri Sep 28 20:08:27 PDT 2007

Yesterday night I finally turned on generator and oscillograph I 
bought.  They worked.  I connected generator to the pin where signal 
from rpm sensor come,  +12V from spare battery,   set ~200Hz which is 
~130M/h.   It worked exactly like on the car - speedo works but odometer 
is intermittent.  It came to stop and resumed when I shook the unit a 
little, or tapped on the PCB.   Disconnected PCB with motor from the 
odometer - free motor works same intermittent.   When it did not work 
the signal from pin 2 and 12, which are motor driving signals,  changed 
its form from nothing to very short, low amplitude (~3-5V) pulses.   I 
also noticed that chip was most sensitive  spot  for tapping.   Having 
no experience with electronics I had no clue what wrong could be with 
chip.  I decided to re-solder everything on the PCB before I starting to 
look for the chip replacement.   After re-soldering I can not get this 
thing to stop.  I have a suspicion that I fixed it.  I probably will  
replace the 15 tooth gear anyway. 

Best regards,

kbogach wrote:
> Update:
> took apart another odometer from 100 '90 (got it at junk yard a year 
> ago).  Found out that I put in the gear into odometer from S4 in 
> correct position (I suspected otherwise).  At this point I stuck 
> without oscillator and oscilloscope.   A few minutes ago I bought them 
> on ebay.   Hopefully they are in working condition.  Price was not bad 
> - $200 for both.    Reminder:  I need to find out why odometer is 
> intermittent while speedo and the gear (usual culprit) are fine.
> I don't like replacing parts with ones I got from junk, in general, if 
> I don't understand  nature of the problem.  You never know what other 
> problems you might  introduce.   If you are not that picky as I am, 
> you still would not be able to replace speedo/odometer unit from type 
> 44  to UrS4 or visa versa.  They have different connectors location.  
> UrS4 has 4 pins togeter, 200 tq has 2 pins in one location and another 
> 2 in another.    But you can solder out wires for speedo's 
> galvanometer  from speedo/odo PCB and swap mechanical part - it seems 
> to be same.   But I am not going to play with it.  After 2 years of 
> not working on my cars I am thrilled to find the problem.
> Disassembling notes: arrow on the speedo from S4 came off relatively 
> easy.  It seems to me, I don't remember for sure as it was about 10 
> month ago, it came off when I pulled it with fingers.  On the type 44 
> speedo, no that the arrows are different, it did not come off even 
> after prying with little, filed thinner open end wrench.  Black 
> plastic cup came off instead with little piece of arrow base.   This 
> cup is fused to the arrow base in 3 points.   Then I heated top of the 
> pin with small soldering iron while pulling the arrow up.  Plastic 
> melted a little and arrow is off.   After that I grabbed the tiny 
> tube-like shaft of the arrow with small pliers and pull it off from 
> the speedo shaft.   On S4's speedo that stub came off with arrow.   
> After that I put arrow shaft on the speedo shaft, heated a little and 
> put the arrow back on the shaft.   After you pulled the arrow shaft 
> with arrow or without arrow off the speedo shaft one time it will come 
> off easy while you pull with fingers.  But it sits tight enough to 
> stay in place on a car.   Black cup was still snug on the arrow, so I 
> did not use any non-drying glue which I would use otherwise.
> Cheers,
> Konstantine

More information about the quattro mailing list