[s-cars] Re:My Hawk HPS Pads for my 993 Big Reds Squeal ..

Rich Dauenhauer rdauenhauer at yahoo.com
Sun Nov 9 17:11:39 EST 2003

Hey Levent(?),
I also am/have been suffering this BS.
Bought my kit incl. Mintex Reds some months ago now,
After a week or so they exhibited the same issues (but
it didnt seem to be heat related) I contacted Tom on
multiple occasions to no avail. His only recomendation
was buy another "different" set of pads from him or
someone else. Ive now tried a couple differernt pads
at some personal expense. Im very dissapointed that
Tom & ECS dont stand beside thier product in that
these "Kits" are engineered and sold to a specific
application (the UrS cars.) The fact that multiple
people have/are suffereing the same problem would make
me think that ECS would step up, but perhaps the only
leverage they recognize is the power of the almighty
95.5 T-Red S6 Avant in Seattle

From: "Levent Cur"
To: <s-car-list at audifans.com>
Date: Sun, 9 Nov 2003 12:14:16 -0500

Hey all I just put on my ECS Stage 2 Kit. I have
Porsche dampeners on the back of the pads and have
greased the carriers as per ECS (Tom's)request. They
still squeal at low speed braking on medium or light
pedal pressure. I'm really upset about this. its so
annoying and loud. Anyone have any ideas? I hope this
turns into a big debate, because I found little bits
and pieces in the archives. Also Elijah (Green urS4),
I met you at GingerMan, I was the guy in the Silver S6
with 18" wheels.  What do you run? Cause yours didn't
squeal at all. By the way my pads don't
squeal when cold.

Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard

More information about the S-car-list mailing list