[s-cars] Fumoto Valve and Michelin Man Issues

Dave Forgie forgied at direct.ca
Sun Jan 18 13:37:57 EST 2004

Kirby:  No, its definitely the Fumoto.  As I lay there (car up on new
"Jack-all" Brand ramps with extensions - Thanks Santa), playing with the
Michelin Man, I wiped the Fumoto.  Two minutes later, it was "wet" again.
Okay.  Problem. (minor?).  But I will check the power steering pump reservoir
just because you've reminded me.  Thanks.

Dave F.

Kirby Smith wrote:

> Dave, I noticed what appeared to be the same Fumoto valve leak when
> changing oil this fall, and put it on the list of things to be looked at
> when I was having some suspension work done.  Turns out that the leak
> was from an x-plug on the hydraulic pump.  Is your hydraulic fluid
> showing any sign of loss?
> kirby
> Dave Forgie wrote:
> >
> > S-gruppees:  I changed my oil yesterday. While doing so I noticed one
> > on-going problem and one "new" one:
> >
> <snip>
> >
> > 2.  I have been running a Fumoto drain valve for years. I thought
> > everything was fine but on closer inspection, i.e. during the time I was
> > playing with the Michelin Man, I noticed that the Fumoto was weeping out
> > the end (not at the ball) where there is a circular plate and an the
> > C-clip.  I don't remember this before.  I didn't do anything different
> > this time.  Has it always been doing this and I didn't notice before
> > because the belly pan got put on too quickly?  (The motor doesn't use
> > any oil in 5000 km). The belly pan has oil and dirt on it but I have
> > never cleaned it. (Going out right now to the pressure car wash to clean
> > it).  Any BTDT's or??
> >
> > TIA
> >
> > Dave F.
> >

More information about the S-CAR-List mailing list