[urq] front end clunk

Michele_Deltergo at KeyBank.com Michele_Deltergo at KeyBank.com
Fri Sep 22 14:57:59 EDT 2006

So far what it is not, sway bar/bushings.  it makes the noise with sway bar
disconnected.  CV axle related, it makes the noise with this removed.
Steering related all is tight and within adjustment.  Wheel bearing is
fully seated and held in place. (It is also new but doesn't guarantee no
problems, just highly unlikely)  Strut mounts replaced, not them. Spring
set on "rubber isolators) (pieces of rad hose) Still clink.  Tie rods new,
all bushing/mount/end bolts all tightened to spec.  All is pointing back to
housing itself and strut though I have a hard time believing there is
enough room in the housing for the strut to move far enough to make this
level of noise.  More when I know more.

This communication may contain privileged and/or confidential information. It
is intended solely for the use of the addressee. If you are not the intended
recipient, you are strictly prohibited from disclosing, copying, distributing
or using any of this information. If you received this communication in error,
please contact the sender immediately and destroy the material in its entirety,
whether electronic or hard copy. This communication may contain nonpublic personal
information about consumers subject to the restrictions of the 
Gramm-Leach-Bliley Act. You may not directly or indirectly reuse or redisclose
such information for any purpose other than to provide the services for which
you are receiving the information.

127 Public Square, Cleveland, OH 44114

If you prefer not to receive future e-mail offers for products or services from
Key send an e-mail to DNERequests at key.com with 'No Promotional E-mails' in the

More information about the urq mailing list