[urq] EFI + MAC-14 maxing ataround 5k RPM

Ben Swann benswann at verizon.net
Tue Oct 23 15:32:57 PDT 2007


I'm absolutely certain there is no fuel pump relay - I wired this thing completely and
purposely left out that feature for now.  There is a relay, but it is a basic switching
relay that is keyed on with ignition and takes power directly off the battery.  I am
going to put a heavier duty relay on just to be sure there is no reliability problem.
The power wire segment to the pump is under 3' and using #10 wire.

I mentioned not beig a fuel pump cutout problem in my original post knowing that this
would be the first thing folks would think of.  So rule it out completely.

There is no RPM or boost related cutout due to relay or intended/programmed function in
the MAC-14 or Megasquirt.


-----Original Message-----
From: Huw Powell [mailto:audi at humanspeakers.com] 
Sent: Tuesday, October 23, 2007 3:34 PM
To: Ben Swann
Cc: urq at audifans.com; quattro at audifans.com
Subject: Re: EFI + MAC-14 maxing ataround 5k RPM

> Things that can be automatically ruled out:
> Fuel pump relay – this does not apply, as I am providing continuous power to the fuel
> pump with a direct feed of #10 wire direct to the pump - relayed of course, but always
> on with ignition.  Once I get engine tuned, I’ll enable cutout relay circuit – that
can actually be done through MS.

Are you *certain* that the FPR is not powering *anything*?  because your 
symptoms are the classic 4 cylinder FPR in 5 cyl car 5200 rpm cutout.

Just suggesting you triple check... like, does the car run with the fpr 

Huw Powell



More information about the urq mailing list