[urq] Resolved! EFI + MAC-14 maxing ataround 5k RPM

Ben Swann benswann at verizon.net
Fri Oct 26 09:23:17 PDT 2007

OK I’m certain I’ve figured out what was going on.  First here is what I did to narrow
things down.  As of yesterday AM I was not sure even if it was an ignition dropout or
problem with fuel injection.  I went through the ignition and rechecked things -
basically all wiring is at or above factory spec, and there is virtually direct battery
connection on coil terminal 15.  I checked to make sure tachometer from UrQ was not
putting any parasitic load on the coil, since this was a difference.  The MAC-14 uses a
dedicated output from the ECU to the model 200 tach.  But there was no difference, and
engine still broke up at around 5000 RPM.


I decided it was time for compression check and to look at the plugs.  I ran the engine
to slightly warm and revved to duplicate the problem, then shut off.  I pulled plugs one
by one as I did a compression check.  Well all the plugs were fouled rich – not gassy
but fairly thick carbon.  I was not surprised and sort-of expected this.  Since they
were not wet, that supported that it was not ignition dropout.  Compression check was
138 +/- 3 PSI on all cyl.  So cleaned plugs and back to diagnosis.  


I studied the latest log and noticed that in a very short interval, the Pulsewidth would
spike just as the RPM was going from about 5K to over 5500 RPM.  The pulsewidth would be
about 7ms and jump quckly to over 14 ms.  It seems that the injectors would go from just
about right to putting way too much fuel in and drowning out the combustion.  Due to all
the cautions I’d seen and heard about tuning too lean,  I had been reluctant to lean
things out, but erred too much on the side of caution.  I had been leaning the table out
awhile back, but it was so out of range, I was not able to notice if I was helping or
hurting how the engine ran. 


I flattened out the VE table map significantly and as I did, the engine was able to
attain and maintain a higher RPM.  I was getting up to around 7000 RPM even.  I leaned
the map out some for the load range, but it is probably still too rich.  I went for  JNR
run.  Jesus!  I know it is not right yet, but basically I can’t tune it much better
without an assistant and subsequently a dyno.  Even going up a long steep hill the car
simply gets going too fast to monitor events as they are happening.  It was raining and
It scared the S#|+ out of me! 


So the upshot of this is, the VE table setting in the over 5000 RPM range were way too
high and the engine became too rich to fast.  The symptoms made me look for an ignition
problem, but now I see what was going on.


I probably have other settings incorrect – For one I set up the base injector settings
to match a 42 lb injector and later found they were 37 lb.  There are more things to
adjust and I don’t even have the modified MAC-14 ECU in there, so only hitting around 2
bar – if that.  Even now, this car is scary fast, and I’m able to drive it around.  I’ll
be installing a Wide Band O2 sensor, and hope to get my G-Tech back from the fellow with
the slipping clutch I left in his car now in Canada.


Thanks for all the feedback and suggestions – even when I check things that aren’t
related to the problem, I end up making them better in the process.





From: Ben Swann [mailto:benswann at verizon.net] 
Sent: Tuesday, October 23, 2007 9:42 AM
To: urq at audifans.com; quattro at audifans.com
Cc: 'Ben Swann'
Subject: EFI + MAC-14 maxing ataround 5k RPM

I think it is safe to rule out fuel delivery as a problem with my EFI’d engine now that
I have replaced fuel pump and assured getting good fuel delivery at all times.  So back
to the problem.  I think the ignition is dropping out at around 5000RPM, but at a loss
on how to verify it and how to fix it.  To review, the engine is completely rebuilt MC-1
with NF head being fed by Megasuirt V2.2 fuel injection through 42 lb injectors – need
to verify as these are Lucas Bluetops, and might be 36#.  

For ignition I am using the MAC-14 with dual knock sensors.  I have the car tuned fairly
well by now in the below 5000 RPM range, and the engine runs great and pulls hard until
it hits about 5000 RPM.  It doesn’t matter what load and engine can be free-revving and
still reaches about a maximum of 5000 RPM.  If I gun the engine briefly, the tach will
hit 6K or so, but gradually increasing RPM it will go to about 5300 RPM and seem like it
is hitting a rev limiter.  Holding the throttle open, the engine bounces – the RPM
oscillates between like 4800 and 5400.  Occasionally I have seen 6000 RPM and holding,
but not able to maintain that result.

Things that can be automatically ruled out:

Fuel pump relay – this does not apply, as I am providing continuous power to the fuel
pump with a direct feed of #10 wire direct to the pump - relayed of course, but always
on with ignition.  Once I get engine tuned, I’ll enable cutout relay circuit – that can
actually be done through MS.

Fuel delivery – I have set at 45 PSI and it maintains good pressure with regulated flow.
There is a pressure port on the regulator that can vary fuel pressure about +/- 5 PSI
depending upon load/manifold pressure.  I see not reason to suspect there is inadequate
fuel flow or pressure in the rail.

There are no codes from the MAC-14.  Most of the fuel injection portion has been
disabled and only providing power to O2 Heater at this time.  MAC-14 is being used
mainly for ignition only.

I swapped coils and it made no difference.

I pulled wires one by one and no one cylinder deviates differently from the others  I
will check plugs and do compression test – again.  When I installed the engine, I had
even compression on all cylinders - consistant with a new engine.  Cap and Rotor are
new.  Engine now has about 2000 miles on it and still running on the break-in oil.

It does not make sense that it is EFI since the cutout happens regardless of how the
engine is being driven or not – the cutout occurs at around 5000 RPM even just opening
the throttle without any engine load.  If it were fuel, I’d think it would happen only
under load.  Possibly the injectors are maxing out, but this does not make sense, as it
should not take much fuel to rev the engine without a load. I also don’t notice any lean
condition when the problem occurs – seeing like a 12:1 on the O2 guage.   Still I won’t
rule out fuel injectors, but ..

I think there is some reason the ignition is dropping out – like not enough current to
the coil when the engine hits around 5000 RPM.  There is of course the long run from the
battery located under the seat.  I ran an additiona #6 wire to a jumper post located
near the coil and then runs down to the starter.  Although the engine cranks faster when
starting, the RPM limit problem is still there.  

I’m wondering if the coil is not saturating, and not enough current is available at
higher RPMs.  Why this would happen on this car and not on a 200?  

It doesn’t make sense – this balanced engine should be good for well over 7000 RPM.  I’m
going to post on some other forums – Megasuirt and MotorGeek, but this seems more like
an ignition problem where the MAC-14 is  providing the ignition.  Maybe installing a
capacitor or battery up front to test
I’m looking for ideas.


More information about the urq mailing list