[V6-12v] Bad fuel pump???

Dr. Gary E. RAFE drgerlists at gmail.com
Wed Jul 19 10:14:25 EDT 2006

"Lino M. Valadas" <l.valadas at rogers.com> wrote:
!My wife's 93 90q (v6 2.8 12v), cranks but does not start.  No fuel.  When I
!whack the gas tank under the car the fuel pump wakes up and the thing
!starts.  Does this mean a bad fuel pump or just bad connections somewhere?
!Any BTDT before I attempt to replace the pump on a full tank of gas of

Very likely a pump starting to fail.
How loud is the pump when it runs ?

The pump in our our 95 90q had been getting a little noisey of late,
until it "failed" on day last month.
Tapping the fuel tank got it going again,
but you could definitely hear it when it ran
after that first failure to start.

I had a local shop replace it (along with the fuel filter)
for about 450$US (fair, considering it's been over a year
since we need to have anything done to the car).

They did comment to me that they needed a special tool
to remove the pump from its mount inside the tank.
You'll certainly want to have a look at the Bentley manual
for more details before getting too far along
(I don't have access to mine at the moment).

I'm interested, too, in reading what other list members
have to say about their BTDT stories.

I suppose if you (or your wife) doesn't mind tapping
the fuel tank prior to starting the car,
you might be able to use up some of that fuel
while you're waiting for your new pump & filter
to arrive !
Dr Gary E RAFE: drgerlists at gmail dot com

More information about the V6-12v mailing list