[V8] 1990 V8 p/s pump

Samuel Mrowka smrowka at gmail.com
Tue Jul 1 05:42:44 PDT 2008

> I also had that "cute" spray last weekend when my pump was acting
> up...except mine arced right onto the main serpentine belt. For the X cap
> that was causing me problems, I first cleaned it out very thoroughly,
> replaced the O-ring, and then applied some high-torque (gray) Permatex on
> the threads and the rim for some peace of mind. That way I *know* if it
> leaked again, it was a structural problem and that the entire pump needed to
> be replaced. Luckily, the pump was fine and just needed to be
> resealed...underside of the engine is nice and dry now. I found out the hard
> way that hydraulic fluid kills grass big-time!

> -Sam
> ------------------------------
> Message: 4
> Date: Sun, 29 Jun 2008 00:47:54 -0600
> From: "Ed Kellock" <ed.kellock at msn.com>
> Subject: Re: [V8] 1990 V8 p/s pump
> To: "'q - V8'" <v8 at audifans.com>
> Message-ID: <BLU109-DAV552A5DA7E92A0C84E70C6839C0 at phx.gbl>
> Content-Type: text/plain;       charset="us-ascii"
> The leak is at the cap on which I replaced the o-ring.  At idle w/o any
> steering activity there's a cute little spray arcing straight over to the
> frame rail.  I'm going to try to replace the o-ring again w/o removing the
> pump.  The cap that's leaking is the one that faces straight toward the
> frame rail.
> Ed
> -----Original Message-----
> From: Ed Kellock [mailto:ed.kellock at msn.com]
> Sent: Saturday, June 28, 2008 12:27 AM
> To: 'q - V8'
> Subject: 1990 V8 p/s pump
> I pulled the pump a couple of weeks ago and replaced an o-ring in a
> leaking x-cap.
> Today, GF returns home from errands with Pentosin gusher.  Everything's
> soaked, including front bumper, headlight, lower door panels, rear tire.
> It's too dirty and wet to tell what's leaking until I clean it up.  I'm
> hoping it's an unrelated failure.  Any thoughts on whether my o-ring
> repair could have caused something else downstream?
> Ed

More information about the V8 mailing list